Security Watch

Keeping Track of patches and hacks in the IT security world.

Google Patches 58 Android Vulnerabilities in February Security Update

Once again, Stagefright Android mediaserver flaws are being patched by Google to help protect Android users from potential security risks.

Android Security

Google released its second Android patch update of 2017 on Feb. 6, providing users of the mobile operating system with patches for 58 different vulnerabilities, up significantly from the 13 flaws Google fixed in its February 2016 Android update.

In the new February 2017 update, 8 vulnerabilities are rated by Google as critical. Among the critical vulnerabilities is CVE-2017-0405, which is a remote code execution vulnerability in the Android Surfaceflinger graphics library.

"A remote code execution vulnerability in Surfaceflinger could enable an attacker using a specially crafted file to cause memory corruption during media file and data processing," Google warns in its advisory. "This issue is rated as Critical due to the possibility of remote code execution within the context of the Surfaceflinger process. "

The Surfaceflinger issue was reported by researchers Scott Bauer and Daniel Micay of Copperhead Security. Micay in particular is no stranger to reporting Android vulnerabilities and was credited back in October 2015 for reporting a security flaw that was dubbed 'Stagefright 2' at the time. The original Stagefright media server flaw was first disclosed in July 2015 and is the vulnerability that led to Google start its monthly patch process in August 2015.

In the February 2017 update, Google is now patching four stagefright related vulnerabilities. Two of the issues (CVE-2017-0406, CVE-2017-0407) are remote code issues in mediaserver that are rated by Google as critical. Additionally, there are two high severity issues that are being patched including a remote code execution vulnerability (CVE-2017-0409) in the libstagefright library, as well as a privilege escalation vulnerability in mediaserver (CVE-2017-0415).

Among the critical issues patched by Google is CVE-2017-0427 which is a privilege escalation vulnerability in the kernel filesystem.

"An elevation of privilege vulnerability in the kernel file system could enable a local malicious application to execute arbitrary code within the context of the kernel," Google warns in its advisory. "This issue is rated as Critical due to the possibility of a local permanent device compromise, which may require reflashing the operating system to repair the device."

Google is also now patching Android for a critical privilege escalation vulnerability (CVE-2014-9914) in the kernel networking subsystem that was first patched in the upstream Linux kernel back in June 2014.

As has been the case in Android updates since August 2015 and the so-called 'QuadRooter' flaws, issues with various Qualcomm components are a leading source of patches in the Google update. With the February 2017 update, there are 19 patched Qualcomm flaws including two rated as critical, 15 rated as high and an additional two flaws that have moderate severity. The patched Qualcomm flaws include remote code execution and privilege escalation issues.

Sean Michael Kerner is a senior editor at eWEEK and InternetNews.com. Follow him on Twitter @TechJournalist.

Sean Michael Kerner

Sean Michael Kerner

Sean Michael Kerner is an Internet consultant, strategist, and contributor to several leading IT business web sites.